Take Command 26.0:

 

La compatibilidad con Windows 7 se ha eliminado de todos los productos (Take Command, TCC, CMDebugy TCC-RT).

 

Excepto por TCC-RT, la compatibilidad con Windows de 32 bits está obsoleta en v26. el v26 Take Command, TCCy CMDebug Todos los instaladores son solo de 64 bits. Los instaladores de 32 bits estarán disponibles previa solicitud para licencias multisistema.

 

El Take Command, TCC, CMDebugy TCC-Los instaladores RT se crean con una nueva versión de Advanced Installer.

 

 

Take Command:

 

Cambió todos los Take Command iconos para un diseño moderno "fluido".

 

La biblioteca del marco GUI se ha actualizado.

 

Las DLL del lenguaje son sustancialmente más pequeñas y se cargan más rápido.

 

Muchas mejoras de rendimiento y tamaño.

 

Take Command ahora se escalará correctamente al moverse entre monitores con diferentes valores de DPI.

 

Soporte agregado para Windows Server 2019.

 

La herramienta de búsqueda de errores de Windows ahora admite códigos de error NTSTATUS.

 

Hay una nueva opción en el menú Opciones para cambiar el directorio de trabajo para Take Command.

 

El menú contextual en las etiquetas de las pestañas tiene una nueva entrada "Buscar" para buscar en la ventana de la pestaña actual.

 

El menú de edición contextual en la ventana de la pestaña tiene una nueva entrada "Buscar" para buscar en la ventana de la pestaña actual.

 

El cuadro de diálogo "Ejecutar" tiene nuevas opciones para seleccionar TCC, CMD, PowerShell o bash.

 

El icono de diálogo "Ejecutar" se ha agregado al menú de acceso rápido en la página Take Command barra de título.

 

El cuadro de diálogo "Ejecutar" se ha agregado al menú INICIO.

 

El Take Command Los cuadros de diálogo se han modificado para que sean más limpios y legibles.

 

La información sobre herramientas para el control deslizante de transparencia (esquina inferior derecha) ahora muestra la configuración de transparencia actual (20 - 255; los valores más altos son más opacos).

 

 

TCC:

 

Everything Search se ha actualizado a 1.4.1.969.

 

Las DLL del lenguaje son sustancialmente más pequeñas y se cargan más rápido.

 

Muchas mejoras de rendimiento y tamaño.

 

El intérprete Lua integrado se ha actualizado a la versión 5.4.

 

La compatibilidad con Python se ha reconstruido con la nueva versión 3.8.2.

 

Soporte agregado para Windows Server 2019.

 

Se han eliminado la mayoría de los límites de tamaño de cadena restantes (excepto aquellos en los que las API de Windows tienen límites).

 

TCC ahora admite listas de alias locales y globales (o ninguna) simultáneamente. TCC buscará primero en la lista local (si existe) una coincidencia; si no encuentra uno, buscará en la lista global. Esto le permite tener un conjunto común de alias (en la lista global) y alias específicos de tareas (en la lista local). Las opciones ALIAS /GL y /LL le permiten especificar qué lista desea utilizar al mostrar/crear/modificar/eliminar alias.

 

TCC ahora admite listas de funciones definidas por el usuario tanto locales como globales (o ninguna) simultáneamente. TCC buscará primero en la lista local (si existe) una coincidencia; si no encuentra uno, buscará en la lista global. Esto le permite tener un conjunto común de funciones (en la lista global) y funciones específicas de tareas (en la lista local). Las opciones FUNCTION /GL y /LL le permiten especificar qué lista desea usar al mostrar/crear/modificar/eliminar funciones.

 

TCC ahora admite listas de historial de comandos locales y globales simultáneamente. Esto es sólo para usuarios avanzados; Generalmente no se recomienda tener ambos tipos. Si solo tiene una lista de historial de comandos local o solo una lista de historial de comandos global, la recuperación del historial funcionará igual que en versiones anteriores. Si tiene listas de historial de comandos locales y globales, al buscar hacia atrás en el historial se buscará primero en la lista local. Si llega al principio de la lista local, la siguiente entrada del historial devuelta será la del final de la lista global. Si busca hacia adelante en la lista global, cuando llegue al final, la siguiente entrada del historial devuelta será el comienzo de la lista local. Si intenta ir más allá del principio de la lista global o del final de la lista local TCC sonará. Tenga en cuenta que el ajuste del historial no es compatible con las listas locales + globales.

 

TCC ahora admite listas de historial de directorio local y global simultáneamente. Esto es sólo para usuarios avanzados; Generalmente no se recomienda tener ambos tipos. Si solo tiene una lista de historial de directorio local o solo una lista de historial de directorio global, la recuperación del historial de directorio funcionará igual que en versiones anteriores. Si tiene listas de historial de directorio local y global, al buscar hacia atrás en el historial se buscará primero en la lista local. Si llega al principio de la lista local, la siguiente entrada del historial devuelta será la del final de la lista global. Si busca hacia adelante en la lista global, cuando llegue al final, la siguiente entrada del historial devuelta será el comienzo de la lista local. Si intenta ir más allá del principio de la lista global o del final de la lista local TCC sonará.

 

Se agregaron dos alias especiales opcionales que le permiten personalizar su entorno según el directorio actual:

 

CD_Dejar - TCC ejecutará este alias cuando esté a punto de cambiar el directorio actual. TCC pasará el nombre del directorio actual (%1) y el nombre del nuevo directorio (%2).

 

CD_Introducir - TCC ejecutará este alias inmediatamente después de cambiar el directorio actual. TCC pasará el nombre del nuevo directorio (%1).

 

 

IDE/depurador por lotes:

 

La biblioteca del marco GUI se ha actualizado.

 

El IDE ahora escalará correctamente al moverse entre monitores con diferentes valores de DPI.

 

El control de edición de Scintilla se ha actualizado a la versión 4.3.2.

 

Muchas mejoras de rendimiento y tamaño.

 

Se amplió la ayuda para el IDE/Debugger.

 

El IDE monitoreará el sistema de archivos para detectar cualquier cambio en los archivos que se están editando. Si otra aplicación modifica un archivo, el IDE mostrará un mensaje notificándole el cambio y preguntándole si desea volver a cargar el archivo actualizado.

 

Se cambiaron todos los íconos IDE a un diseño moderno "Fluido".

 

La mayoría de las entradas del menú IDE tienen íconos, lo que le brinda más opciones para personalizar la barra de herramientas.

 

Se mejoró ligeramente la visualización de la fuente.

 

Hay una nueva opción de inicio después del nombre del archivo para ir a un número de línea:

 

/gotoline:nn

 

Por ejemplo:

 

bdebugger mytest.cmd /gotoline:24 [argumentos del archivo por lotes...]

 

Hay una nueva opción "Colores de sintaxis" en el menú Opciones que le permite seleccionar los colores utilizados en la coloración de sintaxis de una paleta de 16 millones de colores. Cuando hace clic en uno de los botones de color de primer plano o de fondo, el IDE mostrará un cuadro de diálogo de selección de color para permitirle elegir colores.

 

El cuadro de diálogo Búsqueda de errores (Depuración/Búsqueda de errores) ahora admite códigos de error NTSTATUS.

 

El IDE tiene pestañas adicionales para Alias ​​locales, Alias ​​globales, Funciones locales y Funciones globales. Sólo se mostrarán si existe la lista local/global adecuada.

 

Hay una nueva opción en el menú Archivo para recargar el archivo en la pestaña actual desde el disco.

 

Hay una nueva opción en el menú Archivo para eliminar el archivo de la pestaña actual a la papelera de reciclaje.

 

Hay dos nuevas opciones en el menú Archivo para guardar y cargar sesiones. Creas una sesión con la opción de menú "Guardar sesión", que crea un archivo con los nombres de los archivos en las pestañas de ventanas. "Cargar sesión" abrirá los archivos en el archivo *.session que especifique.

 

Hay una nueva opción en el menú Opciones para establecer el color del cursor para las ventanas de edición de pestañas.

 

Hay una nueva opción en el menú Opciones para cambiar el directorio de trabajo del IDE.

 

Hay un nuevo submenú en el menú Opciones para seleccionar la ubicación de la pestaña de la ventana (arriba, abajo, izquierda o derecha).

 

El menú contextual en las etiquetas de las pestañas tiene una nueva entrada "Copiar ruta completa" que copia la ruta completa del archivo en esa pestaña al portapapeles.

 

El menú contextual en las etiquetas de las pestañas tiene una nueva entrada "Cerrar todo" que cierra todas las ventanas de pestañas.

 

La entrada del menú "Pestañas..." se ha movido de Opciones a Editar.

 

Los cuadros de diálogo del IDE se han modificado para que sean más limpios y legibles.

 

La información sobre herramientas para el control deslizante de transparencia (esquina inferior derecha) ahora muestra la configuración de transparencia actual (20 - 255; los valores más altos son más opacos).

 

El cuadro combinado Argumentos por lotes en la barra de herramientas IDE ahora muestra texto de sugerencia si no proporciona argumentos al inicio.

 

Al arrastrar texto en una ventana de edición ahora se desplazará automáticamente la ventana cuando llegue a los bordes.

 

El valor Unicode en la barra de estado para el carácter en la ubicación del cursor ahora admite caracteres multibyte UTF8.

 

Se agregó soporte para UTF8 en TCMD.INI.

 

 

TCEDIT:

 

La biblioteca del marco GUI se ha actualizado.

 

TCEdit ahora se escalará correctamente al moverse entre monitores con diferentes valores de DPI.

 

El control de edición de Scintilla se ha actualizado a la versión 4.3.2.

 

Muchas mejoras de rendimiento y tamaño.

 

Se amplió la ayuda para TCEdit.

 

TCEdit monitoreará el sistema de archivos para detectar cualquier cambio en los archivos que se están editando. Si otra aplicación modifica un archivo, el IDE mostrará un mensaje notificándole el cambio y preguntándole si desea volver a cargar el archivo actualizado.

 

Cambió todos los TCEdit iconos para un diseño moderno "fluido".

 

La mayor parte del TCEdit Las entradas del menú tienen íconos, lo que le brinda más opciones para personalizar la barra de herramientas.

 

Se mejoró ligeramente la visualización de la fuente.

 

TCEdit ahora admite entrada canalizada. Por ejemplo, "directorio | TCEdit" cargará el contenido del directorio en la primera ventana de pestaña.

 

TCEdit ahora admite salida canalizada con la opción de menú "Archivo / Guardar en STDOUT". Esto le permite editar la entrada de la tubería antes de enviarla para que otra aplicación la procese. Por ejemplo:

 

directorio /b | tcedit | alguna aplicación

 

Hay una nueva opción de línea de comando para imprimir el archivo y luego salir TCEdit:

 

tcedit nombre de archivo /impresión

 

Hay una nueva opción de inicio después del nombre del archivo para ir a un número de línea:

 

/gotoline:nn

 

Por ejemplo:

 

tcedit mytest.cmd /gotoline:24 [tuprueba.cmd /gotoline:12 ...]

 

Hay una nueva opción en el menú Archivo para recargar el archivo en la pestaña actual desde el disco.

 

Hay una nueva opción en el menú Archivo para eliminar el archivo de la pestaña actual a la papelera de reciclaje.

 

Hay dos nuevas opciones en el menú Archivo para guardar y cargar sesiones. Creas una sesión con la opción de menú "Guardar sesión", que crea un archivo con los nombres de los archivos en las pestañas de ventanas. "Cargar sesión" abrirá los archivos en el archivo *.session que especifique.

 

Hay una nueva opción "Colores de sintaxis" en el menú Opciones que le permite seleccionar los colores utilizados en la coloración de sintaxis de una paleta de 16 millones de colores. Cuando haces clic en uno de los botones de color de primer plano o de fondo, TCEdit mostrará un cuadro de diálogo de selección de color para permitirle elegir colores.

 

Hay una nueva opción en el menú Opciones para establecer el color del cursor para las ventanas de edición de pestañas.

 

Hay un nuevo submenú en el menú Opciones para seleccionar la ubicación de la pestaña de la ventana (arriba, abajo, izquierda o derecha).

 

El menú contextual en las etiquetas de las pestañas tiene una nueva entrada "Copiar ruta completa" que copia la ruta completa del archivo en esa pestaña al portapapeles.

 

El menú contextual en las etiquetas de las pestañas tiene una nueva entrada "Cerrar todo" que cierra todas las ventanas de pestañas.

 

La entrada del menú "Pestañas..." se ha movido de Opciones a Editar.

 

La información sobre herramientas para el control deslizante de transparencia (esquina inferior derecha) ahora muestra la configuración de transparencia actual (20 - 255; los valores más altos son más opacos).

 

Al arrastrar texto en una ventana de edición ahora se desplazará automáticamente la ventana cuando llegue a los bordes.

 

El valor Unicode en la barra de estado para el carácter en la ubicación del cursor ahora admite caracteres multibyte UTF8.

 

 

plugins:

 

Se agregó soporte para VS 2019.

 

Se agregó compatibilidad con CD_Enter y CD_Leave (ver arriba). Cuando cambias de directorio desde la línea de comando, TCC primero buscará alias de esos nombres; si no encuentra una coincidencia, buscará en los complementos un nombre coincidente.

 

 

Ayuda:

 

La ayuda se creó con una nueva versión (8.0) de Ayuda y Manual.

 

 

Nuevas directivas TMCD.INI:

 

Estas directivas se configuran en el comando OPCIÓN, en los cuadros de diálogo "Inicio" y "Línea de comando":

 

AliasGlobalSize

 

AliasLocalTamaño

 

DirHistoryLocalSize

 

DirHistoryGlobalSize

 

FunciónGlobalSize

 

FunciónTamaño local

 

Alias ​​globales

 

HistoriaDirGlobal

 

Funciones globales

 

Historia global

 

HistoriaGlobalTamaño

 

HistoriaLocalTamaño

 

 

Nuevas variables internas:

 

_osbuildex - Devuelve el número de compilación de Windows + el número de subcompilación (por ejemplo, "19041.84").

 

 

Nuevas funciones variables:

 

@FECHAFMT - Formatea una fecha/hora en un formato personalizado. La sintaxis es:

 

@FECHAFMT[formato de fecha]

 

datos - La fecha a formatear (en formato aaaa-mm-dd hh:mm:ss). Si datos es *, @DATEFMT tiene por defecto la fecha/hora actual. Las fechas válidas son del 1 de enero de 1970 (1970-1-1) al 31 de diciembre de 3000 (3000-12-31). La hora debe estar en formato de 24 horas.

 

formato - El formato personalizado a utilizar. (Tenga en cuenta que normalmente será necesario duplicar o escapar los % para evitar TCC expandirlos antes de que @DATEFMT los vea). Las opciones de formato son:

 

Código

Cadena de reemplazo

%a

Nombre abreviado del día de la semana en la localidad

%A

Nombre completo del día de la semana en la localidad

%b

Nombre abreviado del mes en la localidad

%B

Nombre completo del mes en la localidad

%c

Representación de fecha y hora en la localidad.

%C

El año dividido por 100 y truncado a un número entero, como un número decimal (00−99)

%d

Día del mes como número decimal (01 - 31)

%D

Equivalente a % m /% d /% y

%e

Día del mes como número decimal (1 - 31), donde los dígitos individuales están precedidos por un espacio

%F

Equivalente a % Y-% m-% d

%g

Los últimos 2 dígitos del año semanal ISO 8601 (00 - 99)

%G

El año semanal ISO 8601 como número decimal

%h

Nombre de mes abreviado (equivalente a %b)

%H

Hora en formato de 24 horas (00-23)

%I

Hora en formato de 12 horas (01-12)

%j

Día del año como número decimal (001 - 366)

%m

Mes como número decimal (01 - 12)

%M

Minuto como número decimal (00 - 59)

%n

Un carácter de nueva línea (\n)

%p

El horario local A.M./P.M. indicador de reloj de 12 horas

%r

El reloj local de 12 horas.

%R

Equivalente a % H:% M

%S

Segundo como número decimal (00 - 59)

%t

Un carácter de tabulación horizontal (\t)

%T

Equivalente a % H:% M:% S, el formato de hora ISO 8601

%u

Día laborable ISO 8601 como número decimal (1 - 7; el lunes es 1)

%U

Número de semana del año como número decimal (00 - 53), donde el primer domingo es el primer día de la semana 1

%V

Número de semana ISO 8601 como número decimal (00 - 53)

%w

Día de la semana como número decimal (0 - 6; el domingo es 0)

%W

Número de semana del año como número decimal (00 - 53), donde el primer lunes es el primer día de la semana 1

%x

Representación de fecha para la ubicación

%X

Representación horaria para la localidad.

%y

Año sin siglo, como número decimal (00-99)

%Y

Año con siglo, como número decimal

%z

El desplazamiento de UTC en formato ISO 8601; sin caracteres si se desconoce la zona horaria

%Z

Ya sea el nombre de la zona horaria de la localidad o la abreviatura de la zona horaria, según la configuración del registro; sin caracteres si se desconoce la zona horaria

%%

Signo de porcentaje

 

Los caracteres que no comienzan con % se muestran sin cambios.

 

El # El indicador puede anteponer cualquier código de formato. En ese caso, el significado del código de formato se cambia de la siguiente manera:

 

Código de formato

Sentido

%#a, %#A, %#b, %#B, %#gramo, %#GRAMO, %#h, %#norte, %#pag, %#t, %#u, %#w, %#X, %#z, %#Z, %#%

# se ignora la bandera.

%#C

Representación de fecha y hora larga, apropiada para el lugar. Por ejemplo: "Miércoles 25 de marzo de 2020, 12:41:29".

%#X

Representación de larga duración, adecuada al lugar. Por ejemplo: “Miércoles 25 de marzo de 2020”.

%#d, %#D, %#mi, %#F, %#H, %#I, %#j, %#metro, %#METRO, %#r, %#R, %#S, %#T, %#U, %#V, %#W, %#y, %#Y

Elimine los ceros o espacios a la izquierda (si los hay).

 

La semana ISO 8601 y el año semanal producido por %V, %gy %G, utiliza una semana que comienza el lunes, donde la semana 1 es la semana que contiene el 4 de enero, que es la primera semana que incluye al menos cuatro días del año. Si el primer lunes del año es el 2, 3 o 4, los días anteriores forman parte de la última semana del año anterior. Para esos días, %V es reemplazado por 53, y ambos %g y %G se sustituyen por los dígitos del año anterior.

 

@TIPO DE ARCHIVO - devuelve el tipo de codificación del archivo. La sintaxis es:

 

@TIPO DE ARCHIVO[nombre de archivo]

 

Debe habilitar la entrada UTF8 para TCC reconocer archivos UTF8; consulte OPCIONES / Configuración. Los posibles valores de retorno son:

 

ASCII

UTF8

UTF16

 

 

Variables internas actualizadas:

 

_DOS - Se agregó soporte para Windows Server 2019.

 

 

Funciones variables actualizadas:

 

@CRC32 - si el primer argumento es "sa", trate el segundo argumento como una cadena ASCII. Si el primer argumento es "s8", trátelo como una cadena UTF8.

 

@EVAL - tiene un argumento + opcional al final de la cadena de precisión (es decir, %@eval[nnn=x.y+] para especificar que los resultados positivos deben tener el prefijo +.

 

@HISTORIA - tiene un tercer argumento opcional que especifica si desea la lista del historial local o la lista del historial global. (Si desea especificar la lista de historial que se utilizará, pero no la palabra (segundo argumento opcional) que se devolverá, establezca por el temor a 1.)

 

@HISTORIA[entrada[, por el temor , [L | GRAMO]]]

 

@LÍNEA - Se agregó soporte para archivos UTF8.

 

@LÍNEAS - Se agregó soporte para archivos UTF8.

 

@ MD5- si el primer argumento es "sa", trate el segundo argumento como una cadena ASCII. Si el primer argumento es "s8", trátelo como una cadena UTF8.

 

@SHA1- si el primer argumento es "sa", trate el segundo argumento como una cadena ASCII. Si el primer argumento es "s8", trátelo como una cadena UTF8.

 

@SHA256- si el primer argumento es "sa", trate el segundo argumento como una cadena ASCII. Si el primer argumento es "s8", trátelo como una cadena UTF8.

 

@SHA384- si el primer argumento es "sa", trate el segundo argumento como una cadena ASCII. Si el primer argumento es "s8", trátelo como una cadena UTF8.

 

@SHA512- si el primer argumento es "sa", trate el segundo argumento como una cadena ASCII. Si el primer argumento es "s8", trátelo como una cadena UTF8.

 

 

Comandos actualizados:

 

ALIAS

 

ALIAS ahora admite listas locales y globales simultáneamente. Si tiene definidas listas locales y globales, al mostrar, crear o eliminar alias, puede especificar qué lista desea que utilice ALIAS.

 

/GL - usa la lista de alias global

 

/LL - usa la lista de alias locales

 

Si tiene listas tanto locales como globales definidas y no especifica /GL, ALIAS utilizará de forma predeterminada la lista local.

 

TCC primero buscará alias en la lista local; si no se encuentra TCC buscará en la lista global.

 

Si utiliza la opción /G para convertir una lista de alias local en una lista de alias global, ALIAS no realizará la conversión si ya existe una lista de alias global (por ejemplo, en otro TCC sesión o en SHRALIAS).

 

Se agregaron dos nuevos alias especiales opcionales. CD_Entrar y CD_Dejar (véase más arriba).

 

/R: soporte agregado para archivos UTF8.

 

COLOR

 

Se agregaron nuevas opciones para configurar el color de primer plano y de fondo en un TCC ventana de consola (no una ventana de pestaña TCMD) a 16 millones o 256 colores. Debe ejecutar Windows 10 u 11 y tener ANSI habilitado.

 

/FG r, g, b - establece el color de primer plano en el valor RGB de 16 millones de colores especificado. Los rangos válidos para r, g y b son 0-255.

 

/BG r, g, b - establece el color de fondo en el valor RGB de 16 millones de colores especificado. Los rangos válidos para r, g y b son 0-255.

 

/FG Color - establece el color de primer plano en el valor de 256 colores (xterm) especificado. Rango válido para Color es 0-255.

 

/BG Color - establece el color de fondo en el valor de 256 colores (xterm) especificado. Rango válido para Color es 0-255.

 

/PAG [color] - muestra un cuadro de diálogo de selección de color para seleccionar un color. Debe usarse con /FG o /BG y no puede combinarse con /F.

 

COPIA

 

COPY /S ahora mostrará el número de directorios copiados (si los hay).

 

/CDA: copia los atributos de cada uno de los subdirectorios de origen a los subdirectorios de destino.

 

FECHA

 

FECHA tiene una nueva opción "fechafmt" que muestra la fecha/hora actual en un formato personalizado. Los caracteres de formato son los mismos que los utilizados por la función @DATEFMT (ver arriba). La sintaxis de FECHA es:

 

FECHA [/Fn /T /U "formato"] [mm-dd-aa]] [AM | PM]

 

DEL

 

DEL /S /X ahora mostrará el número de directorios eliminados (si los hay).

 

DELAY

 

DELAY hh:mm:ss o DELAY mm:ss esperará el tiempo especificado.

 

DESCRIBIR

 

DESCRIBE ahora admite archivos de descripción UTF8.

 

DIR

 

/CD:"colordir": define una cadena de coloración de directorio personalizada para usar en lugar de la variable de entorno COLORDIR o la opción ColorDir en TCMD.INI.

 

DIRHISTORIA

 

DIRHISTORY ahora admite listas locales y globales simultáneamente. Al mostrar, crear o eliminar entradas del historial del directorio, puede especificar en qué lista desea que DIRHISTORY busque:

 

/GL: utiliza la lista del historial del directorio global

 

/LL - utiliza la lista del historial del directorio local

 

Al buscar en el historial del directorio, TCC Buscará primero en la lista local (si existe) y luego en la lista global (si existe).

 

Si utiliza la opción /G para convertir una lista del historial del directorio local en una lista del historial del directorio global, DIRHISTORY no realizará la conversión si ya existe una lista del historial del directorio global (por ejemplo, en otro TCC sesión o en SHRALIAS).

 

DO

 

DO eliminará cualquier archivo temporal creado mediante CLIP: en una declaración DO.

 

ENDLOCAL

 

Si solo tiene alias globales definidos, ENDLOCAL restaurará la lista global guardada por SETLOCAL (como en versiones anteriores). Si tiene definidos alias locales y alias globales, ENDLOCAL solo restaurará la lista local guardada por SETLOCAL. Véase también SETLOCAL.

 

ESET

 

/LL (o /LL): utiliza el alias global o la lista de funciones. ESET utilizará de forma predeterminada la lista local si existe; si no es así, ESET buscará una lista global.

 

/G (o /GL): utiliza el alias local o la lista de funciones.

 

TODO LO QUE

 

Everything Search se ha actualizado a la versión 1.4.1.969.

 

El TCC / La integración de Everything Search es más rápida y utiliza menos memoria.

 

EXCEPTO

 

/NM: si no se encuentra ninguna coincidencia para los argumentos en la lista de excepciones, EXCEPT no ejecutará el comando.

 

ENCONTRAR

 

/TE"texto" - Convierte una cadena de texto en una expresión regular y luego realiza una búsqueda de expresiones regulares. No necesita aprender expresiones regularesa,d y /TE se ejecutará 10 veces más rápido que /T. La única limitación es la longitud máxima de línea en el archivo debe ser < 16 Mb.

 

FUNCIÓN

 

FUNCTION ahora admite listas locales y globales simultáneamente. Si tiene listas tanto locales como globales definidas, al mostrar, crear o eliminar funciones, puede especificar qué lista desea que FUNCTION use.

 

/GL - usa la lista de funciones globales

 

/LL - usa la lista de funciones locales

 

Si tiene listas locales y globales definidas y no especifica /GL, FUNCTION utilizará de forma predeterminada la lista local.

 

TCC primero buscará una función definida por el usuario en la lista local; si no se encuentra TCC buscará en la lista global.

 

Si utiliza la opción /G para convertir una lista de funciones locales en una lista de funciones globales, FUNCTION no realizará la conversión si ya existe una lista de funciones globales (por ejemplo, en otro TCC sesión o en SHRALIAS).

 

/R: soporte agregado para archivos UTF8.

 

HISTORIA

 

HISTORY ahora admite listas locales y globales simultáneamente. Al mostrar, crear o eliminar entradas del historial, puede especificar en qué lista desea que HISTORIAL busque:

 

/GL - usa la lista de historial global

 

/LL - usa la lista de historial local

 

Al buscar en el historial, TCC Buscará primero en la lista local (si existe) y luego en la lista global (si existe).

 

Si utiliza la opción /G para convertir una lista de historial local en una lista de historial global, HISTORY no realizará la conversión si ya existe una lista de historial global (por ejemplo, en otro TCC sesión o en SHRALIAS).

 

/R: soporte agregado para archivos UTF8.

 

LIBRERÍA

 

Se agregó soporte para archivos de biblioteca UTF8.

 

Anuncia

 

LIST ahora admite la paginación hacia atrás a través de entradas canalizadas.

 

MEMORIA

 

MEMORIA ahora muestra los alias locales y globales y los tamaños de función.

 

MOVIMIENTO

 

MOVE /S ahora mostrará el número de directorios movidos (si los hay).

 

/MDA: copia los atributos de cada uno de los subdirectorios de origen a los subdirectorios de destino. (Solo es válido si se mueve a otra unidad; de lo contrario, MOVE cambia el nombre del directorio de nivel superior y se conservan todos los atributos del subdirectorio).

 

MSGBOX

 

If TCC está corriendo en un Take Command ventana de pestaña, el cuadro de mensaje se centrará en la ventana de pestaña.

 

/PC: centra el cuadro de mensaje en el escritorio.

 

/X: el cuadro de mensaje no se puede mover.

 

OPCIÓN

 

Hay nuevas opciones para configurar alias globales y/o locales, funciones definidas por el usuario, historial de comandos e historial de directorios.

 

Hay nuevas opciones para configurar los tamaños globales y/o locales para alias, funciones definidas por el usuario, historial de comandos e historial de directorios.

 

PDIR

 

/CD:"colordir": define una cadena de coloración de directorio personalizada para usar en lugar de la variable de entorno COLORDIR o la opción ColorDir en TCMD.INI.

 

PROMPT

 

$: muestra el temporizador de aviso en formato hh:mm:ss.ms.

 

$"fechafmt": muestra la fecha/hora actual en un formato personalizado. Los caracteres de formato son los mismos que los utilizados por la función @DATEFMT (ver arriba).

 

CAJA DE CONSULTAS

 

Se eliminó el límite de longitud máxima (anteriormente 255 caracteres) para la cadena de entrada.

 

Se eliminó el límite de longitud máxima (anteriormente 127 caracteres) para la cadena /CUE.

 

REGDIR

 

/Nb: no muestra el contenido de los valores REG_BINARY.

 

/TS: incluye segundos en la visualización del tiempo de la última escritura.

 

REGDIR ahora mostrará todas las cadenas en REG_MULTI_SZ.

 

REN

 

REN /S ahora mostrará el número de directorios cuyo nombre ha cambiado.

 

SETLOCAL

 

Si solo tiene alias globales definidos, SETLOCAL se comportará como en versiones anteriores y copiará temporalmente la lista global a una lista local y restaurará la lista global en un ENDLOCAL. Si tiene definidos alias locales y alias globales, SETLOCAL solo guardará la lista local, que será restaurada por ENDLOCAL.

 

SETARRAY

 

/R ahora admite archivos UTF8.

 

ATAJO

 

SHORTCUT no intentará calificar completamente el comando, el directorio de inicio o el nombre del archivo de enlace si contienen %. Esto le permite incrustar variables en aquellos argumentos que Windows ampliará.

 

TEE

 

/F"fechafmt": prefije cada línea con una marca de tiempo utilizando un formato personalizado. Los caracteres de formato son los mismos que los utilizados por el @FECHAFMT función (ver arriba).

 

HORA

 

EL TIEMPO tiene una nueva opción "fechafmt" que muestra la fecha/hora actual en un formato personalizado. Los caracteres de formato son los mismos que los utilizados por el @FECHAFMT función (ver arriba). La sintaxis de TIEMPO es:

 

HORA [/S [servidor] /T /U "formato"] [hh[:mm:ss]]] [AM | PM]

 

TUBO

 

Se actualizó la versión de TextPipe Engine de 9.9.4 a 11.6.

 

La dll TextPipeEngine ahora es de 64 bits (para la versión x64 de TCC). (La carga inicial es un poco más lenta, pero todo funciona más rápido).

 

Funciones actualizadas de composición/descomposición Unicode para NFC, NFD, NFKC, NFKD.

 

Bibliotecas PDF actualizadas.

 

Biblioteca convertida de página de códigos actualizada.

 

Biblioteca de expresiones regulares actualizada.

 

Compatibilidad con Unicode actualizada a Unicode 12.1.

 

Nueva opción para Agregar números de línea (para restablecer al comienzo de un nuevo archivo).

 

El filtro Número de línea tiene una nueva opción:

 

/línea=NúmeroInicio,Incremento,OmitirBlanco,NoNúmeroBlanco,FormatoNúmero[,NoRestablecer[,RestablecerNuevoArchivo]]

 

Restablecer nuevo archivo - si es 1, restablece el recuento al comienzo de un nuevo archivo. El valor predeterminado es 0.

 

Se agregó un nuevo filtro de selección:

 

/selection2=tipo, especificación de columna, moverA, procesoIndividualmente, excluirDelimitador, excluirQuotes, delimitador, delimitador personalizado, hasHeader

Tipo: el tipo de filtro a agregar

0 Eliminar columna

1 Restringir líneas

2 restringir columnas

3 Restringir a bytes

4 Restringir a campos delimitados (CSV, Tab, Pipe, etc.)

5 - sin usar

6 Eliminar líneas

7 Eliminar campos delimitados (CSV, Tab, Pipe, etc.)

9 Mover columnas

10 Mover campos delimitados (CSV, Tab, Pipe, etc.)

12 copiar columnas

13 Copiar campos delimitados (CSV, Tab, Pipe, etc.)

17 Eliminar rango de bytes

18 campos de extracción

columnSpec: la lista de elementos entre comillas dobles para eliminar, p. "1...10, 16, 20"

moveTo: entero: dónde mover o copiar las columnas o campos. Predeterminado 1.

ProcessIndividually: si se aplican o no subfiltros a cada campo CSV o Tab individualmente, o a los campos como un valor de cadena. Por defecto es falso.

excluirDelimiter: si se incluye o no la coma o el delimitador de campo Tab al pasar el campo al subfiltro. Verdadero predeterminado.

excluirQuotes: si se incluyen o no las comillas CSV que pueden rodear el campo al pasar el campo al subfiltro. Verdadero predeterminado.

delimitador: (opcional) el índice del delimitador estándar que se utilizará, o 6 para personalizado, valor predeterminado 0 para CSV

customDelimiter: (opcional) el delimitador personalizado entre comillas dobles que se utilizará, en blanco por defecto

hasHeader: (opcional) verdadero si la primera fila del archivo es una fila de encabezado, por defecto es falso.

 

El filtro Fin de línea tiene dos nuevas opciones:

 

/eol=Entrada,Salida,Longitud,LFString, eliminar

 

Cadena LF - la nueva cadena de avance de línea en la salida cuando se elige la opción 4 para Entrada

Eliminar - si se deben eliminar los EOL incorrectos (predeterminado 1)

 

Las especificaciones de columnas para eliminar, extraer y restringir campos delimitados ahora pueden especificar varias columnas en un filtro, p. 6, 9, 61..63.

 

Se agregó formato de salida JSON al filtro de la base de datos.

 

/base de datos=Modo,...

 

Modo = 4 - JSON

 

Se agregaron filtros Convertir pestaña a JSON y Convertir JSON a pestaña.

 

/simple=tipo

 

tipo = 86 - Convertir JSON a pestaña

tipo = 87 - Convertir pestaña a JSON

 

Se agregó el filtro Convertir documentos de Word a RTF.

 

/Simple=tipo

 

tipo = 88 - Convertir documentos de Word a RTF

 

Nueva clasificación por UTF-8 (distingue entre mayúsculas y minúsculas).

 

/ordenar=Tipo,...

 

Tipo = 9 - clasificación UTF8 (no distingue entre mayúsculas y minúsculas)

Tipo = 10 - clasificación UTF8 (distingue entre mayúsculas y minúsculas)

 

/InputClipboardUnicode=[0|1] - En el modo portapapeles, controla si la entrada se maneja como ANSI o Unicode. El valor predeterminado es 0 (ANSI).

 

Opciones agregadas al filtro /Split=:

 

/split=tipo,SplitSize,SplitChar,SplitCharPos,SplitCharCount,SplitLines,SplitFilename[,FirstFileNumber[,PreventOverload]]

 

FirstFileNumber: (opcional) el número del primer archivo, predeterminado 0

PreventOverload: (opcional) verdadero para evitar más de 10,000 archivos en una carpeta, predeterminado falso

 

El valor predeterminado es la codificación UTF8 en lugar de ANSI al cargar/guardar archivos.

 

Filtro de expresiones regulares de Perl mejorado para permitir que los caracteres Unicode delimiten palabras completas.

 

Se actualizaron los filtros de cambio de mayúsculas y minúsculas para que funcionen con texto codificado en UTF-8.

 

Se modificaron los filtros Convertir Word/Excel/PDF a texto para generar texto UTF-8.

 

El filtro Eliminar BOM ahora detecta si ha cambiado el archivo o no y maneja UTF-16 LE correctamente.

 

Los filtros de lista de búsqueda/reemplazo ahora son compatibles con Unicode.

 

Filtro de numeración de líneas mejorado para diferenciar correctamente entre el inicio del archivo y el inicio de la restricción.

 

Manejo de errores mejorado para filtros de especificaciones que no admiten múltiples rangos.

 

Manejo de errores mejorado para filtros de secuencias de comandos y configuraciones de carga e idiomas.

 

Los filtros de especificación de campos ahora admiten nombres de campos con guiones incrustados (-), y los nombres de campos con espacios se pueden usar rodeándolos entre comillas.

 

Ahora se genera una advertencia cuando una especificación de campo no coincide con los nombres de campo encontrados en un archivo.

 

Se mejoró la velocidad de búsqueda/reemplazo de "coincidencia exacta".

 

La lista de texto a palabras ahora reconoce los posesivos en inglés (u otras abreviaturas) que terminan en 's.

 

Se actualizó Eliminar espacios en blanco del inicio y el final de la línea para manejar el ESPACIO IDEOGRAFICO UTF-8 e3 80 80 (común en texto chino).

 

Los filtros de archivos divididos ahora eliminarán el último archivo si no tiene bytes.

 

El filtro dividido ahora procesa macros después de que se haya realizado la numeración de archivos.

 

Los filtros de la base de datos ahora cambian la extensión de salida para que coincida con el formato.

 

El filtro "Extraer URL" ahora admite cualquier esquema, desde los anteriormente admitidos mailto:, http:, https:, nntp:, gopher:, ftp:, ftps: y otros más nuevos como call: y skype:

 

Salida de registro mejorada para proporcionar información para cada tipo de filtro (muy útil para la depuración de filtros).

 

TPIPE ahora busca filtros 'zombis' que sigan el filtro de salida secundario de un filtro T (estos filtros no hacen nada).

 

Nuevo filtro para convertir documentos de Word a RTF.

 

Las entidades HTML ahora distinguen entre mayúsculas y minúsculas.

 

El registro ahora incluye íconos de filtro para una identificación más sencilla.

 

La conversión de CSV a Tab ahora elimina comillas innecesarias.

 

Soporte de OpenOffice para ODT, ODS y ODP.

 

ÁRBOL

 

Se agregó soporte para colorear la salida de TREE. Las opciones de coloración y el formato son los mismos que los de DIR y pueden incluir:

 

Extension

Atributo de archivo

Tamaño del archivo

Fecha/hora del archivo

Tipo ejecutable

Ranges

 

VER

 

/C: muestra la información de la versión en el mismo formato que CMD (es decir, "Microsoft Windows [Versión 10.0.19559.1000]").

 

VER

 

/W - Si en un Take Command ventana de pestaña, mueve la ventana VER a la ventana de pestaña (y la mantiene allí si cambia el tamaño o mueve la ventana). Take Command ventana). si en un TCC ventana de la consola, cambia el tamaño y mueve la ventana VER al mismo tamaño y posición que la TCC ventana (pero puede arrastrar la ventana VER).

 

El menú Editar tiene nuevas opciones para copiar al portapapeles:

 

Copiar línea actual (Ctrl+Y)

 

Copiar CSV línea actual

 

Mayús+clic en el encabezado de la columna CSV para seleccionar la columna completa.

 

Y

 

Hay tres nuevas opciones para marcar la hora de las líneas STDIN que Y escribe en STDOUT:

 

/D: prefije cada línea con la fecha actual (en formato aaaa-mm-dd).

 

/F"formato" - una hora/fecha personalizada formato cuerda. Ver @FECHAFMT (arriba) para obtener detalles sobre formato argumentos

 

/T: prefije cada línea con la hora actual (en formato hh:mm:ss.ms).

 

WMIQUERÍA

 

/Q: evita la visualización del nombre de la propiedad al mostrar propiedades.

 

 

Nuevos comandos:

 

CRÓNICO

 

CHRONIC ejecuta un comando y oculta su salida STDOUT y STDERR a menos que el comando falle (valor de retorno! = 0). Si el comando tiene éxito, no se muestra ningún resultado. La sintaxis es:

 

CRÓNICO [/R] comando ...

 

/R: muestra el resultado si el comando escribe en STDERR. Si no se especifica /R, CHRONIC solo mostrará el resultado si el comando devuelve un código de salida distinto de cero.

 

CHRONIC mostrará la salida STDOUT y STDERR por separado. Por ejemplo:

 

c:\>CRÓNICO comando de prueba

Código de salida: 2

SALIDA ESTÁNDAR:

salida estándar aquí...

ESTDERR:

salida stderr aquí...

 

PIPÍ

 

PEE es similar a TEE, pero en lugar de redirigir STDOUT a múltiples archivos, lo redirige a múltiples comandos secundarios a través de tuberías. La sintaxis es:

 

PEE /= /D /F"formato" /R /T aplicación ...

 

/= - muestra el cuadro de diálogo del comando PEE

 

/D: prefija cada línea con la fecha actual

 

/F"formato" - una hora/fecha personalizada formato cuerda. Ver @FECHAFMT (arriba) para obtener detalles sobre formato argumentos

 

/R - redirigir STDERR también

 

/T: prefija cada línea con la hora actual

 

ESPONJA

 

SPONGE lee la entrada estándar y la escribe en el archivo especificado. A diferencia de la redirección de salida, SPONGE lee todas sus entradas antes de abrir el archivo de salida. Esto permite construir tuberías que leen y escriben en el mismo archivo. SPONGE lee la entrada estándar en un buffer de memoria, por lo que no se recomienda canalizar cantidades extremadamente grandes de datos (es decir, varios gigabytes).

 

La sintaxis es:

 

ESPONJA [/A] Nombre del archivo de salida

 

/A - agregar salida a Nombre del archivo de salida. El valor predeterminado es sobrescribir Nombre del archivo de salida.

 

TS

 

TS lee líneas de STDIN, antepone una marca de fecha/hora y escribe la línea en STDOUT. TS está pensado para usarse en tuberías, cuando se necesita saber cuándo se recibió cada línea. La sintaxis es:

 

TS [/D /T"formato"]

 

/D: prefije cada línea con la fecha actual (en formato aaaa-mm-dd).

 

/T: prefije cada línea con la hora actual (en formato hh:mm:ss.ms).

 

"..." - El formato cuerda. Ver @FECHAFMT (arriba) para obtener detalles sobre formato argumentos

 

Si no especifica ninguna opción, TS tiene por defecto /D /T.