Take Command 25.0:

 

Take Command:

 

Take Command utiliza sustancialmente menos CPU cuando tiene varias pestañas y no utiliza grupos de pestañas ni ventanas divisorias.

 

La comunicación entre Take Command y TCC es mucho más rápido y utiliza menos tiempo de CPU.

 

Recorte, superposición y escalado de sombras de cuadros fijos en entornos de múltiples monitores y múltiples DPI.

 

Se solucionaron muchas inconsistencias en los temas de Office 2013/2016 y Visual Studio 2015.

 

Se ha mejorado la compatibilidad con DPI para los controles Editar, Casilla de verificación y Cuadro combinado.

 

Puede cambiar la transparencia de la ventana TCMD con Ctrl-Shift-Mousewheel.

 

Ahora puede cancelar el registro de cualquier sistema, siempre que tenga la clave de activación original y el nombre de la computadora para cancelar el registro. El cuadro de diálogo de registro tiene un campo "Nombre del sistema" para el nombre de la computadora (que por defecto es el sistema actual). Ingrese el nombre y haga clic en el botón "Anular registro" para eliminar el sistema especificado. TCMD abrirá una página web en su navegador con el resultado de la cancelación del registro.

 

Ahora puede generar una clave manual (una que no requiere activación por Internet) en cualquier sistema, siempre que tenga la clave de activación original y el nombre de la computadora para registrarse, y el sistema donde solicita la clave tenga acceso a Internet. El cuadro de diálogo de registro tiene un campo "Nombre del sistema" para el nombre de la computadora (que por defecto es el sistema actual). Ingrese el nombre y haga clic en el botón "Solicitar clave manual". TCMD abrirá una página web en su navegador que devuelve la clave manual. Copie el valor de esa clave e ingréselo en el campo "Clave de activación" en el cuadro de diálogo de registro en la computadora que desea registrar.

 

Ahora puede mostrar la información de su licencia en el servidor de registro. Abra el cuadro de diálogo de registro, ingrese su clave de activación y haga clic en el botón "Mostrar información de licencia". TCMD abrirá una página web en su navegador que muestra la cantidad máxima de sistemas que puede registrar, los nombres de los sistemas registrados y las fechas en que se registraron.

 

Se agregó una nueva entrada al menú Inicio / Archivo:

 

Borrar búferElimina el contenido del búfer de pantalla de la ventana de pestaña actual.

 

Se agregó una nueva entrada al menú Editar:

 

Copiar+AgregarAgregue la selección actual al contenido existente del portapapeles.

 

Se agregó una nueva entrada al menú Pestañas (y al menú contextual al hacer clic derecho en una etiqueta de pestaña):

 

Separar+OcultarSepara la pestaña, pero la mantiene oculta. Se puede volver a adjuntar con la opción "Adjuntar pestañas".

 

El menú contextual del botón derecho de la ventana de pestañas tiene una nueva opción: "Copiar+Agregar" agregará la selección actual al contenido existente del portapapeles.

 

Si tiene habilitada la opción de selección de Linux, cuando marca un bloque y suelta el botón izquierdo del mouse con la tecla Mayús presionada, TCMD agregará la selección al portapapeles.

 

Si tiene habilitada la opción de selección de Linux, cuando haga doble clic con la tecla Mayús hacia abajo, TCMD agregará la selección al portapapeles.

 

Si tiene habilitada la opción de selección de Linux, cuando haga triple clic con la tecla Mayús presionada, TCMD agregará la línea al portapapeles.

 

Una tecla Ctrl-W cerrará la pestaña actual (como Ctrl-F4), siempre que haya habilitado la tecla de control izquierda o derecha para Take Command. (Ver OPCIONES / Take Command / Pestañas / Windows.)

 

Una tecla Ctrl-Shift-C agregará la selección actual al contenido existente del portapapeles.

 

El control de edición de Scintilla se ha actualizado a la versión 4.2.0.

 

El Analizador de expresiones regulares (Herramientas/RegEx) ahora tiene un temporizador de microsegundos (a la derecha del control de edición "Prueba") que mide el tiempo que tomó evaluar la expresión.

 

El Analizador de expresiones regulares tiene una "hoja de referencia" de sintaxis RE y expresiones comunes.

 

Puedes deslizar el Take Command levante la ventana de la pantalla ("Consola Quake") y vuelva a bajarla con Ctrl-Alt-Enter.

 

Puede resaltar la fila donde se encuentra el cursor con la nueva directiva CursorLineColor en TCMD.INI. Configúrelo con OPCIONES / Take Command / Pestañas / Windows / Línea del cursor.

 

Si cambia el tamaño de fuente de la ventana de pestaña con Ctrl-rueda del mouse o las opciones del menú acercar/alejar, el nuevo tamaño de fuente solo se aplica a la ventana de pestaña actual; por lo que cada ventana de pestaña puede tener su propio tamaño. (Eventualmente, cada ventana de pestaña también admitirá opcionalmente su propia fuente, pero no en esta versión).

 

If Take Command falla o es cancelada por otra aplicación, las ventanas ocultas de la consola se mostrarán después de 5 segundos, para que se puedan cerrar o volver a conectar.

 

 

TCC:

 

TCC se ha reescrito ampliamente para admitir subprocesos múltiples (casi) en todas partes. Por ejemplo, un complemento puede ejecutar otros comandos internos, alias y archivos por lotes sin entrar en conflicto con el hilo principal. Tenga en cuenta que esto no significa que las API de la consola de Windows admitan subprocesos múltiples: si genera resultados desde varios subprocesos simultáneamente, obtendrá resultados confusos. Debido a las limitaciones de Windows, el manejo de eventos de la consola (^C, ^Break, apagado, cierre de sesión, etc.) solo lo ve y procesa el hilo principal.

 

TCC es compatible con la nueva Terminal de Windows 10 (actualmente en versión preliminar).

 

Se cambiaron algunos de los archivos DLL menos utilizados para cargarlos bajo demanda, lo que reducirá ligeramente el tiempo de inicio y el uso de RAM.

 

Se han actualizado todas las bibliotecas de Internet/red/zip de IPWorks.

 

Se ha actualizado la biblioteca de expresiones regulares de Onigmo.

 

Se agregó soporte para Python 3.8.

 

Ahora puede cancelar el registro de cualquier sistema, siempre que tenga la clave de activación original y el nombre de la computadora para cancelar el registro. El cuadro de diálogo de registro tiene un campo "Nombre del sistema" para el nombre de la computadora (que por defecto es el sistema actual). Ingrese el nombre y haga clic en el botón "Anular registro" para eliminar el sistema especificado. TCC abrirá una página web en su navegador con el resultado de la cancelación del registro.

 

Ahora puede generar una clave manual (una que no requiere activación por Internet) en cualquier sistema, siempre que tenga la clave de activación original y el nombre de la computadora para cancelar el registro, y el sistema donde solicita la clave tenga acceso a Internet. El cuadro de diálogo de registro tiene un campo "Nombre del sistema" para el nombre de la computadora (que por defecto es el sistema actual). Ingrese el nombre y haga clic en el botón "Solicitar clave manual". TCC abrirá una página web en su navegador que devuelve la clave manual. Copie el valor de esa clave e ingréselo en el campo "Clave de activación" en el cuadro de diálogo de registro.

 

Ahora puede mostrar la información de su licencia en el servidor de registro. Abra el cuadro de diálogo de registro, ingrese su clave de activación y haga clic en el botón "Mostrar información de licencia". TCMD abrirá una página web en su navegador que muestra la cantidad máxima de sistemas que puede registrar, los nombres de los sistemas registrados y las fechas en que se registraron.

 

El comodín [ ] ahora acepta ! or ^ como el símbolo NOT.

 

Las ventanas emergentes de historial e historial de directorio ahora admiten selección múltiple (con las teclas Mayús o Ctrl + mouse izquierdo) y tienen un menú contextual emergente (botón derecho del mouse) para Copiar, Copiar+Agregar, Cortar o Eliminar. También puede seleccionar varias entradas y ejecutarlas presionando Enter - TCC creará una línea de comando similar a esta:

 

(line1) Y (line2) Y (line3)

 

Hay nuevas opciones para la redirección de salida. Estas opciones anularán las directivas UnicodeOutput y UTF8Output en TCMD.INI. Las opciones de salida canalizada también funcionan con canalizaciones de DOS (es decir, |!:u). Nota: estas opciones sólo funcionan para redirigir la salida desde TCC comandos internos.

 

>:aLa salida redirigida (STDOUT y/o STDERR) es ANSI (caracteres de 8 bits)
>:túLa salida redirigida es UTF16 Unicode
>:8 o >:u8La salida redirigida es UTF8

 

>>:unLa salida redirigida adjunta (STDOUT y/o STDERR) es ANSI (caracteres de 8 bits)
>>:túLa salida redirigida adjunta es UTF16 Unicode
>>:8 o >>:u8La salida redirigida adjunta es UTF8

 

|:aLa salida por tubería es ANSI
|:túLa salida canalizada es UTF16 Unicode
|:8 o |:u8La salida canalizada es UTF8

 

La coloración de directorios (DIR, PDIR, SELECT) ahora admite rangos en la variable COLORDIR o la directiva ColorDir .INI. Consulte el DIR a continuación para obtener más detalles.

 

La coloración de directorios (DIR, PDIR, SELECT) ahora admite tipos de subsistema (Win32, Win64, GUI, CUI) en la variable COLORDIR o la directiva ColorDir .INI. Consulte el DIR a continuación para obtener más detalles.

 

Los rangos de fecha y hora ahora pueden comparar horas UTC agregando una 'U' después de D o T (y la A, C o W opcional) en la especificación de rango. Por ejemplo:

 

/[dos00:00,11:59]

 

Los rangos de tamaño ahora pueden probar el tamaño comprimido (en unidades NTFS con compresión habilitada para el archivo o directorio) agregando una C al argumento S. Por ejemplo, para especificar archivos con un tamaño comprimido entre 100 y 1000 bytes:

 

/[sc100,1000]

 

El Analizador de expresiones regulares (Ctrl-F7) ahora tiene un temporizador de microsegundos (a la derecha del control de edición "Prueba") que mide el tiempo que tomó evaluar la expresión.

 

El Analizador de expresiones regulares tiene una "hoja de referencia" de sintaxis RE y expresiones comunes.

 

Puedes deslizar el TCC levante la ventana de la pantalla ("Consola Quake") y vuelva a bajarla con Ctrl-Alt-Enter. La secuencia de teclas se puede configurar mediante la directiva QuakeHotKey .INI; vea abajo.

 

Puedes minimizar el TCC ventana hacia y desde la bandeja del sistema con Ctrl-Shift-Z. La secuencia de teclas se puede configurar mediante la directiva TrayHotKey .INI; vea abajo.

 

Se redujo el uso de CPU en TCC ligeramente al correr en una Take Command ventana de pestaña.

 

TCC detectará si se está ejecutando como un servicio o si está desconectado antes de solicitar autenticación SSL o SSH, y proporcionará una entrada automática 'Y' (sí).

 

La directiva FileCompletion .INI y la variable de entorno admiten un nuevo tipo:

 

bibliotecas: finalización de tabulación para nombres de funciones de biblioteca

 

 

IDE/depurador por lotes:

 

El control de edición de Scintilla se ha actualizado a la versión 4.2.0.

 

Redibujar en las ventanas de edición es más fluido y rápido.

 

Se mejoraron los tiempos de carga y guardado de archivos grandes.

 

Al cargar un archivo, IDE primero verificará el tipo de archivo (UTF-16, UTF-8, UTF-8 con BOM o ANSI). Si el archivo no tiene una lista de materiales UTF-16 o UTF-8, se lee como un archivo ANSI con la página de códigos de la consola actual y se convierte a UTF-8 antes de editarlo. Se volverá a convertir a un archivo ANSI con la página de códigos actual cuando se guarde. Esto permite que el IDE muestre correctamente caracteres ASCII de bits altos en el editor.

 

El depurador por lotes tiene un nuevo "Comando Expansión" ventana que aparecerá encima de la ventana de pestañas cuando comience a depurar. El comando Expansión La ventana mostrará la línea de comando original, la línea de comando después de la expansión del alias y la línea de comando después de la expansión de la variable. El comando Expansión La ventana es una ventana de acoplamiento, por lo que se puede mover y conectar en otras ubicaciones. Si no quieres ver el comando Expansión ventana, puede desactivarla desde la opción de menú IDE "Ver/Expansión de comandos".

 

Ahora puede acceder paso a paso a grupos de comandos y bucles FOR. Haga clic en el botón "Pasar a" en la barra de herramientas IDE. Verá la línea de comando actual ejecutándose en la ventana "Expansión de comando" (ver arriba).

 

La pestaña "Modificado" tiene una nueva columna "Anterior" que muestra el valor anterior de la variable que acaba de cambiar.

 

Al depurar, la ventana IDE ahora mantendrá la línea actual centrada en la pantalla (a menos que esté en la última página). Esto le permite ver tanto las últimas líneas como las siguientes a ejecutar.

 

Puede cambiar la transparencia de la ventana IDE con Ctrl-Shift-Mousewheel.

 

Las ventanas Ver, Modificar y Punto de interrupción ahora guardarán los anchos de las columnas si las cambia y usarán los nuevos anchos cuando reinicie el IDE.

 

La ventana de edición ahora mantendrá la línea actual resaltada incluso cuando no esté enfocada.

 

La ventana de edición mantendrá de forma predeterminada la misma sangría que la línea anterior. El valor predeterminado se puede cambiar con la opción MantenerIndent en TCMD.INI (ver más abajo).

 

La búsqueda de expresiones regulares (cuadro de diálogo Buscar) ahora utiliza la biblioteca de expresiones regulares de C++11 en lugar del soporte limitado anterior de expresiones regulares.

 

El temporizador del generador de perfiles ahora utiliza los contadores de rendimiento de Windows. La resolución ahora está en milisegundos (001 segundos) en lugar de centésimas (01 segundos).

 

Si estás usando TCC sintaxis (no CMD), y el primer comando en la línea es un interno TCC comando, el IDE mostrará la ayuda de uso rápido en la barra de estado.

 

Se agregó un nuevo submenú al menú Archivo:

 

CodificaciónLos archivos siempre se tratan como UTF-8 dentro del editor. Esta opción le permite especificar cómo se escribirá el archivo cuando se guarde en el disco.        

 

Página de códigos predeterminadaCuando se guarde el archivo, se escribirá utilizando la página de códigos actual.
UTF16 Little EndianCuando se guarde el archivo, se escribirá como UTF-16.
UTF8Cuando se guarde el archivo, se escribirá como UTF-8.
UTF8 con lista de materialesCuando se guarde el archivo, se escribirá como UTF-8 con una lista de materiales inicial

 

Se agregó una nueva entrada al menú Editar:

 

Copiar+AgregarAgregue la selección actual al contenido existente del portapapeles.

 

Se agregó un nuevo submenú al menú Editar:

 

Caracteres de fin de línea

 

CR + LFLas líneas terminan en retorno de carro + avance de línea (valor predeterminado de Windows)
CRLas líneas terminan en un retorno de carro (valor predeterminado en OSX)
LFLas líneas terminan en un salto de línea (predeterminado en Linux)

 

Se agregó una nueva entrada al menú Editar/Avanzado:

 

Alternar plegado actual: activa y desactiva el plegado de la línea actual

 

Se agregaron dos nuevas entradas plegables al menú Ver. (¡Esto será un poco confuso si no activa el margen de plegado en el menú Opciones!)

 

Alternar plegado actual: activa y desactiva el plegado de la línea actual

Alternar todos los pliegues: alterna cada pliegue del archivo

 

Se agregó una nueva entrada al menú Depurar:

 

Evaluar comando: ejecuta el comando especificado en el contexto del archivo por lotes que se está ejecutando actualmente. La salida se muestra en un control de edición desplazable de solo lectura. Tenga en cuenta que el comando que ejecute puede cambiar el resultado del archivo por lotes que se está depurando.

 

El menú contextual del botón derecho de la ventana de pestañas tiene una nueva opción: "Copiar+Agregar" agregará la selección actual al contenido existente del portapapeles.

 

Una tecla Ctrl-Shift-C agregará la selección actual al contenido existente del portapapeles.

 

El Analizador de expresiones regulares (Herramientas/Expresiones regulares...) ahora tiene un temporizador de microsegundos (a la derecha del control de edición "Prueba") que mide el tiempo que tomó evaluar la expresión.

 

El Analizador de expresiones regulares tiene una "hoja de referencia" de sintaxis RE y expresiones comunes.

 

Las ventanas Inspección, Modificado y Puntos de interrupción ahora mostrarán información sobre herramientas al pasar el mouse que contiene el texto completo de una columna, si es demasiado ancha para mostrarse por completo en la columna.

 

Si "sale" (ejecuta hasta el punto de interrupción o finaliza) y está en un archivo por lotes CALL, y si no hay más puntos de interrupción en el archivo actual, regresará al archivo por lotes principal en la línea que sigue a LLAMAR y se desactivará "salir".

 

El depurador no guardará un archivo *.watch si las únicas variables que se supervisan son las predeterminadas ? y _?.

 

 

TCEDIT:

 

El control de edición de Scintilla se ha actualizado a la versión 4.2.0.

 

Mejorado el TCEdit tiempo de inicio.

 

Se mejoraron los tiempos de carga y guardado de archivos grandes.

 

Al cargar un archivo, TCEdit Primero comprobará el tipo de archivo (UTF-16, UTF8, UTF-8 con BOM o ANSI). Si el archivo no tiene una lista de materiales UTF-16 o UTF-8, se lee como un archivo ANSI con la página de códigos de la consola actual y se convierte a UTF-8 antes de editarlo. Se volverá a convertir a un archivo ANSI con la página de códigos actual cuando se guarde. Esto permite TCEdit para mostrar correctamente caracteres ASCII de bits altos.

 

Redibujar en las ventanas de edición es más fluido y rápido.

 

Puedes cambiar el TCEdit transparencia de la ventana con Ctrl-Shift-Rueda del mouse.

 

La ventana de edición ahora mantendrá la línea actual resaltada incluso cuando no esté enfocada.

 

La ventana de edición mantendrá de forma predeterminada la misma sangría que la línea anterior. El valor predeterminado se puede cambiar con la opción MantenerIndent en TCMD.INI (ver más abajo).

 

La búsqueda de expresiones regulares (cuadro de diálogo Buscar) ahora utiliza la biblioteca de expresiones regulares de C++11 en lugar del soporte limitado anterior de expresiones regulares.

 

Se agregó un nuevo submenú al menú Archivo:

 

CodificaciónLos archivos siempre se tratan como UTF-8 dentro del editor. Esta opción le permite especificar cómo se escribirá el archivo cuando se guarde en el disco.        

 

Página de códigos predeterminadaCuando se guarde el archivo, se escribirá utilizando la página de códigos actual.
UTF16 Little EndianCuando se guarde el archivo, se escribirá como UTF-16.
UTF8Cuando se guarde el archivo, se escribirá como UTF-8.
UTF8 con lista de materialesCuando se guarde el archivo, se escribirá como UTF-8 con una lista de materiales inicial

 

Se agregó una nueva entrada al menú Editar:

 

Copiar+AgregarAgregue la selección actual al contenido existente del portapapeles.

 

Se agregó un nuevo submenú al menú Editar:

 

Caracteres de fin de línea

 

CR + LFLas líneas terminan en retorno de carro + avance de línea (valor predeterminado de Windows)
CRLas líneas terminan en un retorno de carro (valor predeterminado en OSX)
LFLas líneas terminan en un salto de línea (predeterminado en Linux)

 

Se agregó una nueva entrada al menú Editar/Avanzado:

 

Alternar plegado actual: activa y desactiva el plegado de la línea actual

 

Se agregaron dos nuevas entradas plegables al menú Ver. (¡Esto será un poco confuso si no activa el margen de plegado en el menú Opciones!)

 

Alternar plegado actual: activa y desactiva el plegado de la línea actual

Alternar todos los pliegues: alterna cada pliegue del archivo

 

El menú contextual del botón derecho de la ventana de pestañas tiene una nueva opción: "Copiar+Agregar" agregará la selección actual al contenido existente del portapapeles.

 

Una tecla Ctrl-Shift-C agregará la selección actual al contenido existente del portapapeles.

 

 

Ayuda:

 

La ayuda está creada con una nueva versión de Ayuda y Manual 7.

 

 

Directivas TMCD.INI:

 

CursorLineColor: establece el color de la línea donde se encuentra el cursor (solo ventanas con pestaña TCMD). Configúrelo con OPCIONES / Take Command / Pestañas / Windows / Línea del cursor.

 

EscResetHistory=yes|NO - Si es así, TCC restablecerá el puntero del historial de comandos al final de la lista cuando presione Escape en el símbolo del sistema.

 

MantenerIndent=YES|no - En IDE & TCEdit editar ventanas, use la misma sangría que en la línea anterior.

 

QuakeHotKey (Intro predeterminado): tecla de acceso rápido para deslizar el Take Command or TCC ventanas "estilo terremoto". La tecla de acceso rápido es siempre Ctrl-Alt-algo; el valor de QuakeHotKey es el último valor. Por ejemplo, para el valor predeterminado Ctrl-Alt-Enter::

 

QuakeHotKey=Entrar

 

RepeatArgument: duplica el argumento anterior en la línea de comando (el valor predeterminado es Shift-F12).

 

ScreenUpdate: número de fotogramas por segundo para el Take Command actualizaciones de ventanas de pestaña. El rango es 1 - 100; el valor predeterminado es 30.

 

TrayHotKey (predeterminado Ctrl-Shift-Z): mueve el Take Command or TCC ventana hacia y desde la bandeja del sistema.

 

Habilitó la sección [Secundaria] (obsoleta, obsoleta, no recomendada).

 

 

Edición de línea de comando:

 

Se agregó una solución alternativa para el error de Windows 10 para permitir el uso de pulsaciones de teclas de selección (es decir, Mayúsculas-Izquierda, etc.) sin habilitar la Consola heredada.

 

Shift-F12 (RepeatArgument) duplicará el argumento anterior en la línea de comando.

 

Ctrl-Retroceso: igual que Ctrl-L (eliminar palabra a la izquierda).

 

Ctrl-Supr: igual que Ctrl-R (eliminar palabra a la derecha).

 

Cambió el valor predeterminado TCC Tecla de edición "deshacer" de Alt-Z a Ctrl-Shift-Z (Windows 10 se comerá la tecla Alt-Z a menos que configures la opción "consola heredada").

 

Cambió el valor predeterminado TCC Tecla de edición "rehacer" de Alt-Y a Ctrl-Shift-Y (Windows 10 se comerá la tecla Alt-Y a menos que configures la opción "consola heredada").

 

 

Nuevas variables internas:

 

Hay una serie de nuevas variables internas para la posición y el estado del GPS. Requieren un GPS (interno o externo) que admita las API de ubicación del sensor de Windows. Tenga en cuenta que es posible que su GPS no admita todas las variables; Si un valor no es compatible, Windows devolverá "Elemento no encontrado". A menos que se especifique lo contrario, los valores devueltos son números decimales (por ejemplo, 38.735122).

 

%_gpsalt - Altitud (desde el nivel del mar) en metros.

 

%_gpsazimuth: Azimut de cada satélite a la vista. Devuelve una lista delimitada por espacios.

 

%_gpselevation: elevación de cada satélite a la vista. Devuelve una lista delimitada por espacios.

 

%_gpserrorradius: precisión de los valores de latitud y longitud, en metros.

 

%_gpsfixquality: calidad de la solución (entero).

 

%_gpsfixtype: tipo de corrección (entero).

 

%_gpshdop - Dilución horizontal de precisión.

 

%_gpsheading: rumbo verdadero.

 

%_gpsids: ID de los satélites a la vista. Devolvió una lista de números enteros delimitada por espacios.

 

%_gpslat - Latitud

 

%_gpslon - Longitud

 

%_gpsmagheading - Rumbo magnético.

 

%_gpsnmea: devuelve la sentencia NMEA como una cadena.

 

%_gpsopmode: modo de funcionamiento del GPS (entero).

 

%_gpspdop - Dilución de posición de precisión.

 

%_gpsprns: números PRN de satélites a la vista. Devuelve una lista de números enteros delimitada por espacios.

 

%_gpssatsinview - Número de satélites a la vista (entero)

 

%_gpssatsused: número de satélite utilizado en la solución (entero).

 

%_gpsselmode: modo de selección de GPS (entero).

 

%_gpssnr: relación señal-ruido de cada satélite a la vista. Devuelve una lista delimitada por espacios.

 

%_gpsspeed - Velocidad en nudos.

 

%_gpsstatus: estado del GPS (entero).

 

%_gpsvdop - Dilución vertical de precisión.

 

 

Nuevas funciones variables:

 

@VARTYPE - Devuelve el tipo (si lo hay) para el nombre de variable especificado. Los valores posibles son:

 

0Sin tipo
1Entero (0-9)
2Decimal (0-9, el carácter decimal y el separador de miles)
3Maleficio (0-9, AF)
4Booleano (0 o 1)
5Alfabético (A-Z y a-z)
6Alfanumérico (A-Z, a-z y 0-9)
7Expresión regular

 

@WINPATH - Convertir del formato de nombre de ruta WSL al formato de Windows. Por ejemplo:

 

echo %@winpath[//mnt/c/windows/system32/notepad.exe]

c: \ windows \ system32 \ notepad.exe

 

@WSLPATH - Convertir del formato de nombre de ruta de Windows al formato WSL. Por ejemplo:

 

echo %@wslpath[c:\windows\system32\notepad.exe]

//mnt/c/windows/system32/notepad.exe

 

 

Funciones variables actualizadas:

 

@EVAL - Se agregó la función log2().

 

@PID - se agregó un segundo argumento opcional que especifica si se deben devolver todos los PID que coinciden con el primer argumento. Por ejemplo:

 

@pid[firefox,+]

 

@TEMPORIZADOR - Ahora utiliza los contadores de rendimiento de Windows para una resolución más alta. La resolución predeterminada de @TIMER está en milisegundos (001 segundos) en lugar de centésimas (0.01 segundos). @TIMER tiene tres nuevos valores para el segundo argumento opcional para devolver el tiempo fraccionado como un valor aritmético:

 

ms - tiempo dividido en milisegundos

nosotros - tiempo dividido en microsegundos

ns - tiempo dividido en nanosegundos

 

@VERSIÓN - Se agregó un nuevo quinto parámetro opcional que especifica si se debe agregar el número de versión al nombre del archivo (5) o anteponerlo a la extensión (0).

 

 

plugins:

 

Los complementos ahora pueden ejecutar cualquier comando (alias, interno, archivo por lotes, etc.) sin entrar en conflicto con el principal. TCC hilo de procesamiento (ver TCC encima).

 

 

Comandos actualizados:

 

ACTIVAR

 

/POS - acepta un * valor para cualquiera de los argumentos. Si el valor es *, ACTIVATE utilizará el valor de posición/ancho/alto existente. Por ejemplo, para cambiar el tamaño de una ventana sin moverla:

 

ACTIVAR "título" /POS=*,*,1200,800

 

Para mover una ventana sin cambiar su tamaño:

 

ACTIVAR "título" /POS=200,400,*,*

 

ASOCIAR

 

/Pn - la opción /P(ause) tiene un argumento opcional n que especifica el número de segundos que se deben esperar hasta que se presione una tecla antes de continuar.

 

/V:verbo- ASSOCIATE tiene como valor predeterminado leer y escribir en SHELL\OPEN\COMMAND. Puede utilizar un verbo diferente especificando la opción /V. Por ejemplo, para indicarle que cree un verbo PRINT para archivos .TXT:

 

ASOCIAR /V:PRINT .txt=%%SystemRoot%%\system32\NOTEPAD.EXE /p %%1

 

ATTRIB

 

/Pn - la opción /P(ause) tiene un argumento opcional n que especifica el número de segundos que se deben esperar hasta que se presione una tecla antes de continuar.

 

CHCP

 

/Pn - la opción /P(ause) tiene un argumento opcional n que especifica el número de segundos que se deben esperar hasta que se presione una tecla antes de continuar.

 

COLOR

 

COLOR ahora admite cambiar la paleta de colores de la consola con un archivo .INI (por ejemplo, como lo usa la utilidad ColorTool) o un archivo .ITERMCOLORS. La sintaxis es:

 

COLOR /F nombre de archivo

 

Si estás corriendo en un Take Command ventana de pestaña, COLOR pasará los nuevos colores a TCMD para actualizar la ventana de pestaña. Puede tener una paleta de colores diferente en cada ventana de pestaña.

 

DIR

 

La coloración del directorio (usando la variable de entorno COLORDIR u OPCIÓN/Colores/Colores del directorio) ahora admite todos los tipos de rangos (tamaño, fecha, hora, descripción, propietario y exclusión). La sintaxis es la misma que para los rangos en un comando interno. Por ejemplo, para mostrar archivos de entre 100 y 1000 bytes en verde brillante:

 

establecer colordir=/[s100,1000]:bri verde;

 

La coloración de directorios ahora admite colores para tipos de subsistemas de archivos. Los subsistemas soportados son:

 

EXETYPE_WIN32GUIAplicación GUI de Windows x86
EXETYPE_WIN32CUIAplicación de consola Windows x86
EXETYPE_WIN64GUIAplicación GUI de Windows x64
EXETYPE_WIN64GUIAplicación de consola Windows x64
EXETYPE_DOSAplicación DOS (16 bits) (obsoleta)
EXETYPE_POSIXAplicación POSIX (obsoleta)
EXETYPE_EFIAplicación EFI

 

Por ejemplo, para mostrar aplicaciones de consola de 32 bits en verde brillante y aplicaciones de consola de 64 bits en rojo brillante:

 

establecer colordir=EXETYPE_WIN32CUI:bri verde;EXETYPE_WIN64CUI:bri rojo

 

/-C: elimina los separadores de miles al mostrar tamaños de archivos (para compatibilidad con CMD.EXE).

 

/Pn - la opción /P(ause) tiene un argumento opcional n que especifica el número de segundos que se deben esperar hasta que se presione una tecla antes de continuar.

 

ENUMSERVIDORES

 

/Pn - la opción /P(ause) tiene un argumento opcional n que especifica el número de segundos que se deben esperar hasta que se presione una tecla antes de continuar.

 

COMPARTIMIENTOS DE ENUMERACIONES

 

/Pn - la opción /P(ause) tiene un argumento opcional n que especifica el número de segundos que se deben esperar hasta que se presione una tecla antes de continuar.

 

TODO LO QUE

 

La Take Command / TCC La distribución ahora incluye ES.EXE, la interfaz de línea de comandos para TODO (incluida una versión x64 para Windows x64).

 

PARA

 

El formato ~a (atributos de visualización) se ha actualizado para que coincida con el comportamiento actual de CMD con atributos extendidos (incluido el comportamiento de CMD de no mostrar todos los atributos extendidos).

 

GOSUB

 

GOSUB ahora admite la llamada de subrutinas en otro archivo cuando ese archivo está comprimido.

 

CABEZA

 

/Pn - la opción /P(ause) tiene un argumento opcional n que especifica el número de segundos que se deben esperar hasta que se presione una tecla antes de continuar.

 

IF

 

ISVISIBLE "título": ejecuta el comando si la ventana especificada es visible. (Esto significa que Windows ha configurado la bandera de visibilidad; no significa que la ventana sea necesariamente visible en su escritorio.

 

IFF

 

ISVISIBLE "título": ejecuta el comando si la ventana especificada es visible.

 

INSTALADO

 

/Pn - la opción /P(ause) tiene un argumento opcional n que especifica el número de segundos que se deben esperar hasta que se presione una tecla antes de continuar.

 

LIBRERÍA

 

/Pn - la opción /P(ause) tiene un argumento opcional n que especifica el número de segundos que se deben esperar hasta que se presione una tecla antes de continuar.

 

PAUSAR

 

/C: después de presionar una tecla, borra el mensaje y no imprime un CR/LF.

 

PDIR

 

La coloración de directorios ahora admite rangos (consulte DIR para obtener más detalles).

 

La coloración de directorios ahora admite tipos de subsistemas (consulte DIR para obtener más detalles).

 

/D - cambió el significado de "colorear" a "no colorear" (para que coincida con DIR y SELECT).

 

/Pn - la opción /P(ause) tiene un argumento opcional n que especifica el número de segundos que se deben esperar hasta que se presione una tecla antes de continuar.

 

ENCHUFAR

 

/Pn - la opción /P(ause) tiene un argumento opcional n que especifica el número de segundos que se deben esperar hasta que se presione una tecla antes de continuar.

 

IMPRESIÓN

 

/S impresora - configurar la impresora predeterminada.

 

PRIORIDAD

 

Si solo proporciona un PID o un título de ventana, PRIORITY mostrará la prioridad actual.

 

/Pn - la opción /P(ause) tiene un argumento opcional n que especifica el número de segundos que se deben esperar hasta que se presione una tecla antes de continuar.

 

PROMPT

 

La resolución del temporizador PROMPT (= metachar) ahora está en milisegundos (001 segundos) en lugar de centésimas (01 segundos).

 

REGDIR

 

/Pn - la opción /P(ause) tiene un argumento opcional n que especifica el número de segundos que se deben esperar hasta que se presione una tecla antes de continuar.

 

/X: muestra los valores REG_DWORD, REG_DWORD_BIG_ENDIAN y REG_QWORD en hexadecimal. Sólo válido cuando se usa con /V y /D.

 

SELECCIONAR

 

La coloración de directorios ahora admite rangos (consulte DIR para obtener más detalles).

 

La coloración de directorios ahora admite tipos de subsistemas (consulte DIR para obtener más detalles).

 

SERVICIOS

 

/I: muestra los PID de los servicios. Tenga en cuenta que los servicios detenidos devolverán 0 para el PID, al igual que los servicios de Windows.

 

SYNC

 

/WAIT=n: pausa durante n milisegundos entre cada bloque copiado del archivo de origen al de destino. Esto es útil para redes lentas y copias de archivos muy grandes; evita que SYNC monopolice todas las E/S de la red.

 

COLA

 

/Pn - la opción /P(ause) tiene un argumento opcional n que especifica el número de segundos que se deben esperar hasta que se presione una tecla antes de continuar.

 

Lista de tareas

 

/Pn - la opción /P(ause) tiene un argumento opcional n que especifica el número de segundos que se deben esperar hasta que se presione una tecla antes de continuar.

 

MINUTERO

 

TIMER ahora utiliza los contadores de rendimiento de Windows para mayor precisión. La resolución predeterminada del TEMPORIZADOR ahora está en milisegundos (001 segundos) en lugar de centésimas (0.01 segundos).

 

/L: cuando se usa con /S (tiempo fraccionado) o TIMER OFF, muestra el resultado en milisegundos.

 

/M: cuando se usa con /S (tiempo fraccionado) o TIMER OFF, muestra el resultado en microsegundos.

 

/N: cuando se usa con /S (tiempo fraccionado) o TIMER OFF, muestra el resultado en nanosegundos.

 

COMUNÍCATE

 

/CD: crea el directorio especificado si no existe.

 

ÁRBOL

 

/Pn - la opción /P(ause) tiene un argumento opcional n que especifica el número de segundos que se deben esperar hasta que se presione una tecla antes de continuar.

 

TIPO

 

/Pn - la opción /P(ause) tiene un argumento opcional n que especifica el número de segundos que se deben esperar hasta que se presione una tecla antes de continuar.

 

UNQLITE

 

Actualizado a UnQLite 1.1.9.

 

VER

 

Compatibilidad con DPI por monitor (Windows 10 Creators Update 1703 y superior). Esto significa que V se ajustará automáticamente cuando se mueva entre monitores de diferente escala.

Mayús+clic en el encabezado de la columna CSV para seleccionar la columna completa.

Comando Copiar CSV para copiar columnas CSV (con delimitador) al portapapeles.

Se agregó la opción de línea de comando /QUIET para imprimir.

 

VENTANA

 

/POS - acepta un * valor para cualquiera de los argumentos. Si el valor es *, WINDOW utilizará el valor de posición/ancho/alto existente. Por ejemplo, para cambiar el tamaño de una ventana sin moverla:

 

VENTANA /POS=*,*,1200,800

 

Para mover una ventana sin cambiar su tamaño:

 

VENTANA /POS=200,400,*,*